1С Режим Конфигуратор


         

Договор еще не был заключен


    НеПроводитьДокумент();

  КонецЕсли;

  Если Договор.ДатаДоговора>ДатаДок Тогда

// Договор еще не был заключен на дату документа

    Предупреждение("Неверная дата договора");

    НеПроводитьДокумент();

  КонецЕсли;

// Теперь будем заполнять поля регистра "Взаиморасчеты"

  Регистр.Взаиморасчеты.Контрагент = Контрагент;

  Регистр.Взаиморасчеты.Договор = Договор;

  Регистр.Взаиморасчеты.Сумма = Сумма;

// Движение – поступление денег за продаваемый нами товар

// ФлагДвижения = 4

  Регистр.Взаиморасчеты.ФлагДвижения = 4;

// Наш долг возрос, либо долг контрагента уменьшился – на регистр

// пишем сумму приходом

  Регистр.Взаиморасчеты.ДвижениеПриходВыполнить();

КонецПроцедуры

  • Закрываем модуль документа;


  • Закроем окно свойств документа;


  • Переходим к редактированию журнала. Находим журнал "ДвижениеДенег";


  • Входим в редактирование журнала;


  • Добавим новую графу;


  • Идентификатор – "Сумма";


  • В возможных значениях отметим Документ.ПриходДенег.Шапка.Сумма;


  • В выбранных значениях появилось указание на поле документа "Приход денег" "Сумма";


  • Входим в форму списка журнала;


  • Разместим графы журнала как будет удобнее, и поменяем им ширину, чтобы все было видно;


  • Закроем форму списка журнала и окно свойств журнала;


  • Сохраним конфигурацию;


  • 2.14 Работа с документом.

    Документ готов. Проверим его в работе.

  • Открываем 1С:Предприятие в монопольном режиме;


  • Через меню "Операции" команда "Управление оперативными итогами";


  • Ставим дату актуальности итогов на 01.10.2000;


  • Нажимаем [Установить];


  • Появился вопрос "Изменить Точку Актуальности итогов";


  • Отвечаем [Да];


  • Нам сообщают, что изменение точки актуальности завершено. Подтверждаем получение сообщения (подробнее см. "Руководство пользователя");


  • Выходим из окна управления итогами;


  • Из нового раздела меню "Документы" вызываем документ приход денег;



  • Содержание  Назад  Вперед