1С Режим Конфигуратор


         

Перейдем на закладку таблица, создадим


        Мы=Долг;

        Нам=0;

      ИначеЕсли Долг<0 Тогда

        Мы=0;

        Нам=-Долг;

      КонецЕсли;

      Таб.ВывестиСекцию("Группа");

    Иначе

      Наз="("+СокрЛП(Строка(ТЭ.Код))+") "+СокрЛП(ТЭ.Наименование);

      Если  Долг=0 Тогда

        Продолжить;

      ИначеЕсли Долг>0 Тогда

        Мы=Долг;

        Нам=0;

        ИтогоМы=ИтогоМы+Мы;

      ИначеЕсли Долг<0 Тогда

        Мы=0;

        Нам=-Долг;

        ИтогоНам=ИтогоНам+Нам;

      КонецЕсли;

      Таб.ВывестиСекцию("Строка");

    КонецЕсли;

  КонецЦикла;

  Таб.ВывестиСекцию("Итого");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

  • Перейдем на закладку таблица, создадим шаблон, такого вида:



  • Закроем форму отчета;


  • Теперь будем включать наш отчет в меню. В окне метаданных перейдем на закладку "Интерфейсы";


  • Меню Действия, команда "Редактировать". Редактировать меню;


  • Входим в редактирование строки "новая колонка...";



  • Название пишем "Отчеты";


  • [ОК];


  • Открываем появившийся раздел меню "Отчеты";


  • Открываем подраздел меню "новый...";



  • Выбираем объект – Отчеты.Взаиморасчеты;


  • Поля Название, Подсказка заполнились автоматически. Их можно поменять;


  • [ОК];


  • Меню Действия команда "Тест" вызовет окошко, где будет показано, как будет выглядеть наше меню;


  • Закрываем тестовое окно;


  • Закрываем окно редактирования меню;


  • Возвращаемся к дереву метаданных;


  • Сохраняем конфигурацию;


  • Входим в 1С:Предприятие;



  • Содержание  Назад  Вперед