1С Режим Конфигуратор


         

Необязательный параметр. Положительное целое число




<Номер>


Необязательный параметр. Положительное целое число — номер выборки. Если раньше было открыто несколько выборок по счету.




<Счет>


Необязательный параметр. Конкретное значение счета, которое нужно получить из выборки.


Пример.
БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 Цикл
Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();
КонецЦикла;


ВыбратьКорСчета

ПолучитьКорСчет


Синтаксис

ВыбратьКорСчета(<ФлагВсе>, <ФлагДК>, <Номер>)

ПолучитьКорСчет(<Номер>, <Счет>)
Пример:
БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 Цикл
БухИтоги.ВыбратьКорСчета();

Пока БухИтоги.ПолучитьКорСчет() = 1 Цикл
Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();
КонецЦикла;
КонецЦикла;




ВыбратьВалюты

ПолучитьВалюту


Синтаксис:

ВыбратьВалюты(<ФлагВсе>, <ФлагДК>, <Номер> , <РазвСальдо>, <Сортировка>)

ПолучитьВалюту(<Номер>, <Валюта>)
Пример:
БухИтоги.Запрос(Дата1, Дата2);

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 цикл
БухИтоги.ВыбратьВалюты();

Пока БухИтоги.ПолучитьВалюту() = 1 цикл
ДебВ = БухИтоги.ДО(2);

КредВ = БухИтоги.КО(2);
КонецЦикла;
КонецЦикла;




ВыбратьПериоды

ПолучитьПериод


Синтаксис:

ВыбратьПериоды(<ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>)

ПолучитьПериод(<Номер>, <ДатаНачалаПериода>)
Пример:
БухИтоги.ВыполнитьЗапрос(Дата1, Дата2, , , , , "Месяц");

БухИтоги.ВыбратьСчета();

Пока БухИтоги.ПолучитьСчет() = 1 цикл
БухИтоги.ВыбратьПериоды();

Пока БухИтоги.ПолучитьПериод() = 1 цикл
Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();
КонецЦикла;
КонецЦикла;




ВыбратьСубконто

ПолучитьСубконто


Синтаксис:

ВыбратьСубконто(<Индекс>, <ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>, <Сортировка>, <ПорядокОбхода>)

ПолучитьСубконто(<Индекс>, <Номер>, <Субконто>)

Содержание  Назад  Вперед