1С Режим Конфигуратор


         

БухИтоги.ИспользоватьСубконто


Пример:
БухИтоги.ИспользоватьСубконто(ВидыСубконто.Материалы, , 1);

БухИтоги.ИспользоватьСубконто(ВидыСубконто.Склады, , 1);

БухИтоги.ВыполнитьЗапрос(ДатаНач, ДатаКон, "10");

БухИтоги.ВыбратьСубконто(1);

Пока БухИтоги.ПолучитьСубконто(1) = 1 цикл
БухИтоги.ВыбратьСубконто(2);

Пока БухИтоги.ПолучитьСубконто(2) = 1 цикл
Деб = БухИтоги.ДО();

Кред = БухИтоги.КО();
КонецЦикла;
КонецЦикла;




ВыбратьКорСубконто

ПолучитьКорСубконто


Синтаксис:

ВыбратьКорСубконто(<Индекс>, <ФлагВсе>, <ФлагДК>, <Номер>, <РазвСальдо>, <Сортировка>, <ПорядокОбхода>)

ПолучитьКорСубконто(<Индекс>, <Номер>, <Субконто>)
БухИтоги.ИспользоватьСубконто(ВидыСубконто.Товары, , 1);

БухИтоги.ИспользоватьКорСубконто(ВидыСубконто.Клиенты, , 1);

БухИтоги.ВыполнитьЗапрос(ДатаНач, ДатаКон);

БухИтоги.ВыбратьСубконто();

Пока БухИтоги.ПолучитьСубконто() = 1 цикл
БухИтоги.ВыбратьКорСубконто();

Пока БухИтоги.ПолучитьКорСубконто() =1 цикл
Деб = БухИтоги.КорДО();

Кред = БухИтоги.КорКО();
КонецЦикла;
КонецЦикла;



Содержание  Назад  Вперед