1С Режим Конфигуратор


   теплоход дмитрий пожарский        

Отчет курьера


Данный документ оформляет результат поездки курьера по путевому листу. Отмечается количество фактически доставленных товаров. Экранная форма документа выглядит следующим образом:

Пользователь указывает путевой лист, по которому отчитывается курьер. При этом автоматически заполняется табличная часть документа. Пользователь может подкорректировать колонку "Доставлено" в соответствии с фактически доставленным количеством товара. При установке флажка "Недоставленные товары возвращены на склад" товары из регистра Доставка переходят в регистр Остатки, т.е. курьер нам ничего не должен.

При проведении документа совершаются движения в регистрах:

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

Если Доставлено > 0 Тогда

Регистр.Доставка.Товар = Товар;

Регистр.Доставка.Клиент = Клиент;

Регистр.Доставка.Цена = Цена;

Регистр.Доставка.Заказ = Заказ;

Регистр.Доставка.ДатаДоставки = ДатаДоставки;

Регистр.Доставка.Количество = Доставлено;

Регистр.Доставка.Сумма = Сумма;

Регистр.Доставка.ДвижениеРасходВыполнить();

Регистр.Заказы.Товар = Товар;

Регистр.Заказы.Клиент = Клиент;

Регистр.Заказы.ДатаДоставки = ДатаДоставки;

Регистр.Заказы.Цена = Цена;

Регистр.Заказы.Заказ = Заказ;

Регистр.Заказы.Количество = Доставлено;

Регистр.Заказы.Сумма = Сумма;

Регистр.Заказы.ДвижениеРасходВыполнить();

Регистр.Доходы.Товар = Товар;

Регистр.Доходы.Клиент = Клиент;

Регистр.Доходы.Доход = Сумма;

Регистр.Доходы.ДвижениеВыполнить();

КонецЕсли;

Если Фл_ВозвратОстатков=1 Тогда

Если Доставлено < Заказано Тогда

Регистр.Доставка.Товар = Товар;

Регистр.Доставка.Клиент = Клиент;

Регистр.Доставка.Цена = Цена;

Регистр.Доставка.Заказ = Заказ;

Регистр.Доставка.ДатаДоставки = ДатаДоставки;

Регистр.Доставка.Количество = Доставлено;

Регистр.Доставка.Сумма = Сумма;

Регистр.Доставка.ДвижениеРасходВыполнить();

Регистр.Остатки.Товар = Товар;

Регистр.Остатки.Количество = Заказано - Доставлено;

Регистр.Остатки.ДвижениеПриходВыполнить();

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры



Содержание  Назад  Вперед